Formspree - Some submissions not sending – Incident details
All systems operational
Some submissions not sending
Resolved
Degraded performance
Started almost 3 years agoLasted about 5 hours
Affected
Form Processing
Degraded performance from 6:11 PM to 11:37 PM
Submissions Processing
Degraded performance from 6:11 PM to 11:37 PM
Updates
Resolved
Resolved
Our email provider has resolved the issue. All emails have been sent out. If you are still not receiving emails, please contact us for more information.
Investigating
Investigating
A small number of submission emails are not sending due to an internal issue with our email provider. We will continue to provide an update as more information is made available.