Formspree - Degraded performance – Incident details

Degraded performance

Resolved
Degraded performance
Started 4 days agoLasted about 3 hours

Affected

Form Processing

Degraded performance from 3:45 PM to 6:19 PM

Submissions API

Degraded performance from 3:45 PM to 6:19 PM

Submissions Processing

Degraded performance from 3:45 PM to 6:19 PM

SendGrid - Mail Sending

Dashboard

Degraded performance from 3:45 PM to 6:19 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Monitoring
    Monitoring
    We implemented a fix and are currently monitoring the result.
  • Investigating
    Investigating
    We are currently investigating this incident.