Formspree - Degraded performance – Incident details

Degraded performance

Resolved
Degraded performance
Started 14 days agoLasted 43 minutes

Affected

Form Processing

Operational from 7:10 PM to 7:34 PM, Degraded performance from 7:34 PM to 7:53 PM, Operational from 7:34 PM to 7:53 PM

Submissions API

Operational from 7:10 PM to 7:53 PM

Submissions Processing

Operational from 7:10 PM to 7:34 PM, Degraded performance from 7:34 PM to 7:53 PM

SendGrid - Mail Sending

Dashboard

Operational from 7:10 PM to 7:53 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Monitoring
    Monitoring
    We implemented a fix and are currently monitoring the result.
  • Identified
    Identified
    We are continuing to work on a fix for this incident.
  • Investigating
    Investigating
    We are currently investigating this incident.