Formspree - Degraded performance – Incident details

Degraded performance

Resolved
Operational
Started 23 days agoLasted about 4 hours

Affected

Form Processing

Operational from 2:08 PM to 6:19 PM

Submissions API

Operational from 2:08 PM to 6:19 PM

Submissions Processing

Operational from 2:08 PM to 6:19 PM

SendGrid - Mail Sending

Dashboard

Operational from 2:08 PM to 6:19 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Monitoring
    Monitoring

    The fix has been implemented and we are monitoring the situation.

  • Identified
    Identified

    Users may experience degraded performance when using the dashboard and delays in receiving submissions. We have identified the problem and are implementing a fix.