Formspree - Submissions Taking Longer to Process – Incident details

Submissions Taking Longer to Process

Resolved
Degraded performance
Started 3 months agoLasted about 1 hour

Affected

Form Processing

Degraded performance from 6:30 PM to 6:50 PM, Operational from 6:50 PM to 7:50 PM

Submissions Processing

Degraded performance from 6:30 PM to 6:50 PM, Operational from 6:50 PM to 7:50 PM

Updates
  • Resolved
    Resolved

    We have confirmed the incident has been resolved

  • Monitoring
    Monitoring

    We implemented a fix and are monitoring the result.

  • Investigating
    Investigating

    We are currently investigating an incident where submissions are taking longer to process than normal. All submissions continue to be received and stored but may take longer to process to plugins and email notifications.