Resolved
Form processing delayed

Started
September 17, 2023 at 5:30:00 PM
Status
Resolved after about 6 hours

Impact

Degraded performance
Affected
Form Processing
Submissions API
Submissions Processing
SendGrid - Mail Sending
  • Resolved
    Resolved

    This incident has been resolved.

  • Identified
    Identified

    Queue size has spiked causing form processing delays. Queues are clearing and form processing should return to normal within the next 4 hours.