Formspree - Error loading submissions on dashboard – Incident details
All systems operational
Error loading submissions on dashboard
Resolved
Partial outage
Started 7 months agoLasted about 16 hours
Affected
Dashboard
Partial outage from 3:44 AM to 5:51 PM, Operational from 5:51 PM to 8:00 PM
Updates
Resolved
Resolved
We have confirmed that all dashboards are operating as would normally be expected.
Monitoring
Monitoring
We implemented a fix and are currently monitoring the result.
Identified
Identified
We have identified the underlying cause and will be rolling out a fix to ensure submissions can load on the dashboard. Only forms that do not belong to a project are affected.