Completed
Submission Processing Maintenance

Status
Resolved after 39 minutes
Started
July 07, 2022 at 2:30 PM
Completed
July 07, 2022 at 3:09 PM
Affects
Form Processing
Submissions Processing
  • Completed
    July 07, 2022 at 3:09 PM

    Maintenance has completed successfully. All previous submissions that didn't process should now be successfully processed!

  • In progress
    July 07, 2022 at 2:36 PM

    Maintenance is now in progress.

  • Planned
    July 07, 2022 at 2:30 PM

    In order to improve our system performance, we are performing maintenance on our submission processing systems. All form submissions will continue to work, but you may see a delay in submission emails and plugin dispatches. Once the maintenance is complete, all systems should resume processing as normal