Resolved
Networking Issues

Started
June 21, 2022 at 6:58:17 AM GMT+00:00
Status
Resolved after 25 minutes

Impact

Major outage
Affected
Dashboard
Website
Form Processing
Submissions API
Submissions Processing
  • Resolved
    June 21, 2022 at 7:23:20 AM GMT+00:00

    A fix has been implemented and we are monitoring the situation.

  • Investigating
    June 21, 2022 at 6:58:17 AM GMT+00:00

    Investigating networking issues at one of our main upstream networking providers causing errors and timeouts to Formspree’s services