Completed
Scheduled Database Maintenance

Starts
February 24, 2022 at 5:00 PM
Status
Resolved after less than a minute
Affects
Form Processing
Submissions API
Form Processing
Submissions Processing
Dashboard
  • Completed
    February 24, 2022 at 5:00 PM

    This maintenance was cancelled due to an overlapping incident.

  • Planned
    February 24, 2022 at 5:00 PM

    In order to increase the stability and scalability of our systems, we are making updates to our primary database. A brief period of service interruption may be experienced.