Resolved
Error Creating Forms and Projects

Started
August 17, 2021 at 1:54:54 PM GMT+00:00
Status
Resolved after 25 minutes

Impact

Operational
Affected
Dashboard
Form Processing
Submissions API
  • Resolved
    August 17, 2021 at 2:19:32 PM GMT+00:00

    Our team has confirmed that our fix has worked and resolved this issue.

  • Monitoring
    August 17, 2021 at 2:02:51 PM GMT+00:00

    We implemented a fix and currently monitoring the result.

  • Investigating
    August 17, 2021 at 1:54:54 PM GMT+00:00

    We are currently investigating this incident.