Resolved
Increased error rates

Started
June 29, 2021 at 4:10:59 PM GMT+00:00
Status
Resolved after 27 minutes

Impact

Operational
Affected
Dashboard
Form Processing
Submissions API
Submissions Processing
  • Resolved
    June 29, 2021 at 4:38:00 PM GMT+00:00

    Formspree has observed recovery of all services and has resolved this incident.

  • Monitoring
    June 29, 2021 at 4:34:54 PM GMT+00:00

    We implemented a fix and currently monitoring the result.

  • Identified
    June 29, 2021 at 4:28:53 PM GMT+00:00

    The issue has been identified and a fix is being implemented.

  • Investigating
    June 29, 2021 at 4:10:59 PM GMT+00:00

    We are currently investigating an elevated number of request timeouts.