Resolved
Increased Latency on Submission Processing

Started
March 09, 2021 at 2:18:00 PM GMT+00:00
Status
Resolved after about 2 hours

Impact

Operational
Affected
Form Processing
Submissions Processing
  • Resolved
    March 09, 2021 at 4:44:00 PM GMT+00:00

    From 12:49 to 16:34 UTC, submission processing was delayed. This issue is now resolved. If you still any issues, please reach out to our support team

  • Identified
    March 09, 2021 at 3:10:00 PM GMT+00:00

    There is a delay in processing submissions. Current customer impact includes delayed mail send and plugin dispatch

  • Investigating
    March 09, 2021 at 2:18:00 PM GMT+00:00

    We're currently investigating elevated latency when processing form submissions. We'll post an update soon.